Voo Virtual
Olá, seja bem-vindo(a) ao Voo Virtual. Caso ainda não seja membro da nossa comunidade, registre-se, para que possa participar ativamente e ter acesso a todos os conteúdos do site.
Por favor leia as regras do fórum aqui antes de postar, para evitar advertências e suspensão.


Menu Addons não aparece

Ver o tópico anterior Ver o tópico seguinte Ir em baixo

Menu Addons não aparece

Mensagem por cveloso em Sex 26 Maio 2017, 16:32

Olá Pessoal,

Estou tendo muita dificuldade em conseguir com que o MENU ADDONS seja exibido no PREPAR3D V3.

Já assisti vários tutoriais, mas mesmo tendo seguido as orientações não obtive sucesso.

Fiz as alterações necessárias no arquivo DLL.XML e no SIMOBJECT.CFG e no entanto sem qualquer sucesso.

Não tenho muitos PLUGINS instalados na pasta MODULE e não compreendo a razão pela qual o menu mencionado não e exibido.

Dessa forma acabo ficando restrito ao XPLANE 11 para realizar voos pela IVAO, pois o principal problema em não ter acesso ao MENU ADDONS é não conseguir acesso ao IVAP.

Abaixo segue meu DLL.XML e meu SIMOBJECT.CFG para que os mais experientes possa analisar e tentar resolver.

Agradeço desde já a paciência e boa vontade em ajudar.

DLL.XML




 Launch
 dll.xml
 False
 False
 

   VistaMare Core
   True
   False
   VistaMare\ViMaCoreX.dll
 

 

   FSUIPC 4
   False
   Modules\FSUIPC4.dll
 

   

   CMetroXml
   True
   true
   .\CMeteoXml.dll
 

 

   carenavigraph
   False
   .\carenavigraph.dll
 

 

   PMDG HUD interface
   False
   PMDG\DLLs\PMDG_HUD_interface.dll
   module_init
   module_deinit
 

 

 IvAp
 False
 D:\Program Files\IVAO\IvAp v2\ivap_fsx_bootstrap.dll
 < /Commandline>





+++++++++++++++++++++++++++++++++++++++++++++++++++

SIMOBJECT.CFG

[Entry.0]
Title=Default Airplanes
Path=SimObjects\Airplanes
Required=True
Active=True
[Entry.1]
Title=Default Avatars
Path=SimObjects\Avatars
Required=True
Active=True
[Entry.2]
Title=Default Rotorcraft
Path=SimObjects\Rotorcraft
Required=True
Active=True
[Entry.3]
Title=Default Ground Vehicles
Path=SimObjects\GroundVehicles
Required=True
Active=True
[Entry.4]
Title=Default Boats
Path=SimObjects\Boats
Required=True
Active=True
[Entry.5]
Title=Default Animals
Path=SimObjects\Animals
Required=True
Active=True
[Entry.6]
Title=Default Misc
Path=SimObjects\Misc
Required=True
Active=True
[Entry.7]
Title=Default Submersible
Path=SimObjects\Submersible
Required=True
Active=True
[Entry.8]
Title=Default Weapons
Path=SimObjects\Weapons
Required=True
Active=True
[Entry.9]
Title=Default Countermeasures
Path=SimObjects\Countermeasures
Required=True
Active=True
[Entry.10]
Title=Ultimate Traffic 2
Path=SimObjects\UT2 Aircraft
Required=True
Active=True
[Entry.11]
Title=IVAO MTL
Path=SimObjects\IVAO_MTL
Required=False
Active=True

cveloso
Aspirante
Aspirante

Masculino
Inscrito em : 01/02/2011
Mensagens : 13
Reputação : 0
Idade : 40
Simulador preferido : PREPAR3D V3
Emprego/lazer : Comissário e Aluno PP
Nacionalidade : Brasil

Voltar ao Topo Ir em baixo

CORREÇÃO ARQUIVO DLL.XML

Mensagem por cveloso em Sex 26 Maio 2017, 16:39




Launch
dll.xml
False
False


VistaMare Core
True
False
VistaMare\ViMaCoreX.dll



FSUIPC 4
False
Modules\FSUIPC4.dll



CMetroXml
True
true
.\CMeteoXml.dll



carenavigraph
False
.\carenavigraph.dll



PMDG HUD interface
False
PMDG\DLLs\PMDG_HUD_interface.dll
module_init
module_deinit



IvAp
False
D:\Program Files\IVAO\IvAp v2\ivap_fsx_bootstrap.dll
< /Commandline>



cveloso
Aspirante
Aspirante

Masculino
Inscrito em : 01/02/2011
Mensagens : 13
Reputação : 0
Idade : 40
Simulador preferido : PREPAR3D V3
Emprego/lazer : Comissário e Aluno PP
Nacionalidade : Brasil

Voltar ao Topo Ir em baixo

Re: Menu Addons não aparece

Mensagem por Paulo Stavis em Sex 26 Maio 2017, 19:01

Seria necessário postar o arquivo no formato em que ele é escrito (e não com os espaços que você colocou, tem que conter tudo incluindo as linhas ).
Geralmente você não precisa inserir nada manualmente, o trabalho é feito pelos instaladores dos programas.
Se quiser posso ver se acho algum erro, poste o texto igual ao do arquivo. Ou envie-o para algum servidor na nuvem (dropbox/mega/etc).
avatar
Paulo Stavis
Brigadeiro
Brigadeiro

Masculino
Inscrito em : 07/04/2011
Mensagens : 2830
Reputação : 602
Idade : 25
Simulador preferido : P3Dv4
Nacionalidade : Brasil

Voltar ao Topo Ir em baixo

Re: Menu Addons não aparece

Mensagem por cveloso em Sex 26 Maio 2017, 19:19

Olá,

Obrigado por responder prontamente. Segue anexo os arquivos conforme solicitado.

DLL.XML
https://mega.nz/#!Eq4zwAJS!WArBhAV4OyNH1ceEIFk_Duza1tyskSf8FbyheYCF-Q0

SIMOBJECT.CFG
https://mega.nz/#!J3JWBbpY!w0Gleew7plyOj9tCW4VWDGYC6HRdxbJEQoYl3FaMWBs

Mais uma vez muitíssimo obrigado.
Abraço

cveloso
Aspirante
Aspirante

Masculino
Inscrito em : 01/02/2011
Mensagens : 13
Reputação : 0
Idade : 40
Simulador preferido : PREPAR3D V3
Emprego/lazer : Comissário e Aluno PP
Nacionalidade : Brasil

Voltar ao Topo Ir em baixo

Re: Menu Addons não aparece

Mensagem por Paulo Stavis em Sex 26 Maio 2017, 21:04

cveloso escreveu:Olá,

Obrigado por responder prontamente. Segue anexo os arquivos conforme solicitado.

Mais uma vez muitíssimo obrigado.
Abraço

Encontrei os seguintes erros no dll.xml (indico a linha, o que está errado e após o "->" está o correto):
Código:
Linha 6: Launch.ManualLoad>False</Launch.ManualLoad> ->  <Launch.ManualLoad>False</Launch.ManualLoad>
Linha 42: </Launch.Addon> -> </SimBase.Document> (o arquivo precisa fechar com essa linha e não com uma /launchaddon)~

Fiz a correção do arquivo e envio o link do mesmo em sequencia. Não sei se vai resolver o problema mas não custa tentar:

https://www.dropbox.com/s/gky53cok75vots1/dll.xml?dl=0

A linha do IVAP aponta para a seguinte localidade: D:\Program Files\IVAO\IvAp v2\ivap_fsx_bootstrap.dll. Só peço que verifique se o caminho está correto pois não utilizo IVAO.

O segundo arquivo, simobjects.cfg, não tem relação com o menu pois ele somente lista onde o simulador deve procurar por aeronaves.
Caso o problema não seja resolvido o que você pode tentar é remover algumas entradas do .cfg e deixar somente a do FSUIPC, por exemplo. Pode também remover todas e tentar reinstalar o FSUIPC para que ele reinstale a sua entrada e apareça o menu.
avatar
Paulo Stavis
Brigadeiro
Brigadeiro

Masculino
Inscrito em : 07/04/2011
Mensagens : 2830
Reputação : 602
Idade : 25
Simulador preferido : P3Dv4
Nacionalidade : Brasil

Voltar ao Topo Ir em baixo

Re: Menu Addons não aparece

Mensagem por cveloso em Sab 27 Maio 2017, 03:14

Paulo Stavis escreveu:
cveloso escreveu:Olá,

Obrigado por responder prontamente. Segue anexo os arquivos conforme solicitado.

Mais uma vez muitíssimo obrigado.
Abraço

Encontrei os seguintes erros no dll.xml (indico a linha, o que está errado e após o "->" está o correto):
Código:
Linha 6: Launch.ManualLoad>False</Launch.ManualLoad> ->  <Launch.ManualLoad>False</Launch.ManualLoad>
Linha 42: </Launch.Addon> -> </SimBase.Document> (o arquivo precisa fechar com essa linha e não com uma /launchaddon)~

Fiz a correção do arquivo e envio o link do mesmo em sequencia. Não sei se vai resolver o problema mas não custa tentar:

https://www.dropbox.com/s/gky53cok75vots1/dll.xml?dl=0

A linha do IVAP aponta para a seguinte localidade: D:\Program Files\IVAO\IvAp v2\ivap_fsx_bootstrap.dll. Só peço que verifique se o caminho está correto pois não utilizo IVAO.

O segundo arquivo, simobjects.cfg, não tem relação com o menu pois ele somente lista onde o simulador deve procurar por aeronaves.
Caso o problema não seja resolvido o que você pode tentar é remover algumas entradas do .cfg e deixar somente a do FSUIPC, por exemplo. Pode também remover todas e tentar reinstalar o FSUIPC para que ele reinstale a sua entrada e apareça o menu.

Olá, infelizmente não resolveu o problema. depois de algumas tentativas resolvi desinstalar o P3D e começar do zero.
Uma vez finalizada a instalação do P3D prossegui para o FSUIP e IVAP V2. Ocorre que ao abrir o P3D a aba Addons estava lá e FSUIP também.

Parti então para inserção da linha de comando que no arquivo DLL.XML e Simobject.cfg.
Para minha surpresa a aba addons sumiu.

Voltei ao arquivo DLL.XML e excluí a linha de comando do IVAP e então a aba addons voltou a ser exibido.

O caminho de instalação está correto, mas mesmo assim não funciona.
Sinceramente não tenho mais ideia do que fazer.

Serei obrigado a desconsiderar a possibilidade de voar na IVAO utilizando o P3D.

Se tiver ideia de qualquer outro procedimento estarei aguardando.

Mais uma vez obrigado.

cveloso
Aspirante
Aspirante

Masculino
Inscrito em : 01/02/2011
Mensagens : 13
Reputação : 0
Idade : 40
Simulador preferido : PREPAR3D V3
Emprego/lazer : Comissário e Aluno PP
Nacionalidade : Brasil

Voltar ao Topo Ir em baixo

Re: Menu Addons não aparece

Mensagem por Paulo Stavis em Sab 27 Maio 2017, 09:06

Excelente, pelo menos chegamos ao causador do problema. Dei uma verificada sobre usar o IVAP no P3D e vejo que é possível, porém é necessário editar manualmente a dll.xml. A unica possibilidade que vejo é o caminho estar incorreto. A linha do IVAP no dll.xml que lhe enviei estava correta (formatação e dados necessários).

Verifique se o caminho está realmente correto. A linha aponta para a unidade D:\Program Files\IVAO\IvAp v2\ivap_fsx_bootstrap.dll enquanto em outro tópico a linha de outro colega apontava para C:\Program Files (x86)\IVAO\IvAp v2\ivap_fsx_bootstrap.dll.
Note que no seu caso ele aponta pra D:\Program Files enquanto a do colega vai para C:\Program Files (x86).

Não resolvendo sugiro procurar ajuda no forum da propria IVAO: http://forum.ivao.aero/index.php?board=322.0
avatar
Paulo Stavis
Brigadeiro
Brigadeiro

Masculino
Inscrito em : 07/04/2011
Mensagens : 2830
Reputação : 602
Idade : 25
Simulador preferido : P3Dv4
Nacionalidade : Brasil

Voltar ao Topo Ir em baixo

Re: Menu Addons não aparece

Mensagem por cveloso em Sab 27 Maio 2017, 16:36

Olá,

Mais uma vez obrigado por dedicar tempo e paciência a resolver meu problema.

Achei interessante que veja algumas janelas da instalação para que possa avaliar melhor se está tudo dentro da normalidade.

A janela abaixo é uma mensagem exibida logo após configurar o caminho do FSX e do P3D bem no início da instalação. Perceba que ele menciona não ter encontrado o executável do P3D, o que não é verdade.

https://snag.gy/ewWpVs.jpg

O caminho estava correto apesar de não estar igual ao que me passou as linha de comando que verifiquei em vários tutoriais. Resolvi refazer a instalação com o caminho que mencionado pela sua linha de comando.

https://snag.gy/AmE9jO.jpg

Mesmo depois de inserir o caminho conforme imagem acima (C:\Program Files (x86)\IVAO\IvAp v2\ivap_fsx_bootstrap), a aba referente ao Ivap não é apresentada e como antes, além disso, desabilita a aba Addons como pode ver nas imagens abaixo.

https://snag.gy/hOKTBb.jpg

https://snag.gy/pmQTLC.jpg

Pensei inclusive que pelo fato de estar instalando o Ivap em uma outra unidade diferente da C:, que isso pudesse estar gerando algum conflito, mas como pode ver, mesmo na unidade C: o problema voltou a ser apresentado.

Vou postar todo o conteúdo desse post lá e ver o que podem fazer. Honestamente estou bem desanimado, mas mesmo assim, obrigado por sua atenção.


cveloso
Aspirante
Aspirante

Masculino
Inscrito em : 01/02/2011
Mensagens : 13
Reputação : 0
Idade : 40
Simulador preferido : PREPAR3D V3
Emprego/lazer : Comissário e Aluno PP
Nacionalidade : Brasil

Voltar ao Topo Ir em baixo

Re: Menu Addons não aparece

Mensagem por Paulo Stavis em Sab 27 Maio 2017, 17:19

cveloso escreveu:Olá,

Mais uma vez obrigado por dedicar tempo e paciência a resolver meu problema.

Achei interessante que veja algumas janelas da instalação para que possa avaliar melhor se está tudo dentro da normalidade.

A janela abaixo é uma mensagem exibida logo após configurar o caminho do FSX e do P3D bem no início da instalação. Perceba que ele menciona não ter encontrado o executável do P3D, o que não é verdade.

https://snag.gy/ewWpVs.jpg

O caminho estava correto apesar de não estar igual ao que me passou as linha de comando que verifiquei em vários tutoriais. Resolvi refazer a instalação com o caminho que mencionado pela sua linha de comando.

https://snag.gy/AmE9jO.jpg

Mesmo depois de inserir o caminho conforme imagem acima (C:\Program Files (x86)\IVAO\IvAp v2\ivap_fsx_bootstrap), a aba referente ao Ivap não é apresentada e como antes, além disso, desabilita a aba Addons como pode ver nas imagens abaixo.

https://snag.gy/hOKTBb.jpg

https://snag.gy/pmQTLC.jpg

Pensei inclusive que pelo fato de estar instalando o Ivap em uma outra unidade diferente da C:, que isso pudesse estar gerando algum conflito, mas como pode ver, mesmo na unidade C: o problema voltou a ser apresentado.

Vou postar todo o conteúdo desse post lá e ver o que podem fazer. Honestamente estou bem desanimado, mas mesmo assim, obrigado por sua atenção.


Reativei meu cadastro na IVAO pra poder dar uma procurada, acabei achando seu post lá... Vi que no tutorial eles falam pra copiar o executável do P3D e renomeá-lo pra FSX. Você chegou a fazer isso? Não sei que diferença faz mas as vezes o instalador dá problema por não ter isso.
É tudo que eu posso pensar. Daqui pra frente só se alguem da IVAO puder lhe ajudar. Pelo menos tentamos lol

PS1: Cuidado com os espaços no dll.xml. Na foto que você mandou há um espaço no ultimo . Sei que esses arquivos são chatinhos com sintaxe e as vezes por um espaço ele dá problema. Tente sempre manter ele ajeitado pra evitar qualquer problema.
PS2: Já estamos no P3Dv4 e a IVAO ainda não resolveu criar vergonha e fazer um instalador melhor com suporte ao v3? Vergonha...
avatar
Paulo Stavis
Brigadeiro
Brigadeiro

Masculino
Inscrito em : 07/04/2011
Mensagens : 2830
Reputação : 602
Idade : 25
Simulador preferido : P3Dv4
Nacionalidade : Brasil

Voltar ao Topo Ir em baixo

Re: Menu Addons não aparece

Mensagem por cveloso em Sab 27 Maio 2017, 20:41

Cara, misteriosamente, depois de muitas intervenções, não faço ideia de como, mas agora está funcionando. As últimas alterações que fiz foi seguindo o passo-a-passo do fórum da IVAO e o que fato de diferente eu fiz foi a duplicação do arquivo prepar3d.exe e o renomei para FSX.EXE.
Isso feito copiei as linha de comando do arquivo dll.xml alteranto o caminho do arquivo ivap_fsx_bootstrap.dll e voilá!
Mais uma vez quero agradecê-lo pela atenção em resolver o problema.
Grande Abraço e bons voo pra nós.

cveloso
Aspirante
Aspirante

Masculino
Inscrito em : 01/02/2011
Mensagens : 13
Reputação : 0
Idade : 40
Simulador preferido : PREPAR3D V3
Emprego/lazer : Comissário e Aluno PP
Nacionalidade : Brasil

Voltar ao Topo Ir em baixo

Re: Menu Addons não aparece

Mensagem por Paulo Stavis em Dom 28 Maio 2017, 11:24

cveloso escreveu:Cara, misteriosamente, depois de muitas intervenções, não faço ideia de como, mas agora está funcionando. As últimas alterações que fiz foi seguindo o passo-a-passo do fórum da IVAO e o que fato de diferente eu fiz foi a duplicação do arquivo prepar3d.exe e o renomei para FSX.EXE.
Isso feito copiei as linha de comando do arquivo dll.xml alteranto o caminho do arquivo ivap_fsx_bootstrap.dll e voilá!
Mais uma vez quero agradecê-lo pela atenção em resolver o problema.
Grande Abraço e bons voo pra nós.

Poisé, imaginei que seria alguma besteira tentar isso mas já que eles instruem a fazer assim é porque algum motivo tem. Imagino que se o instalador não encontra o executável ele não instala alguma coisa. Serviço mal feito por parte deles igual comentei anteriormente.
Bons voos!
avatar
Paulo Stavis
Brigadeiro
Brigadeiro

Masculino
Inscrito em : 07/04/2011
Mensagens : 2830
Reputação : 602
Idade : 25
Simulador preferido : P3Dv4
Nacionalidade : Brasil

Voltar ao Topo Ir em baixo

Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo


 
Permissão deste fórum:
Você não pode responder aos tópicos neste fórum